We recommend OpenCart 3.x for security reasons when connecting with the app. 3.x is stable and secure according to OpenCart advice. In order to deploy in 2.3.x some changes are needed on the OpenCart page.